Skip to main content
Agency Program 50% cashback. 10% commissions. Priority support. Built for growing agencies. 50% cashback for agencies Speak to the team Join free
Advanced Access Manager icon

Advanced Access Manager

v6.9.46
by AAM Plugin · 4.2 (419 reviews)

All you need to manage access to WordPress websites on the frontend, backend and API levels for any role, user or visitors.

100K+ active installs Updated Feb 10, 2025 Tested to 6.7.2 Requires PHP 5.6.0
Try Demo Download
Pre-installed Ready in ~10s No card
Advanced Access Manager

About Advanced Access Manager

Advanced Access Manager (AAM) is a WordPress plugin that allows you to have complete control over your website. It offers features like security audits, access management for different roles and users, and developer-friendly options. AAM prioritizes security and privacy, and does not alter your website's database or capture any external data.

Screenshots

Advanced Access Manager screenshot
Advanced Access Manager screenshot
Advanced Access Manager screenshot
Advanced Access Manager screenshot
Advanced Access Manager screenshot
Advanced Access Manager screenshot
Advanced Access Manager screenshot
Advanced Access Manager screenshot
Advanced Access Manager screenshot
Advanced Access Manager screenshot
Advanced Access Manager screenshot

Frequently asked questions

What is Advanced Access Manager (AAM)?
Advanced Access Manager (AAM) is a robust WordPress plugin designed to help you control every aspect of your website. It allows you to manage access to WordPress websites on the frontend, backend, and API levels for any role, user, or visitor.
What are some key features of AAM?
Key features include a security audit service, unparalleled flexibility in defining access controls, and comprehensive access management for roles, users, and visitors. It also offers a developer-friendly interface and ad-free experience.
Does AAM offer free support?
Yes, AAM provides accessible support, allowing users to get help directly from their admin area without being a paid customer.
Are all features of AAM free?
While most features are free, some advanced functionalities require premium add-ons. The plugin transparently indicates when an upgrade is needed for these features.
What are some popular features of AAM?
Popular features include managing backend menu access, customizing WordPress roles and capabilities, and handling JWT authentication. It also allows for the creation of temporary user accounts.

Changelog

6.9.46

6.9.45

6.9.44

  • Removed: AI Chatbot service. We are moving it all to aamportal.com website as Virtual assistant
  • Removed: Contact form. We are changing our customer support policy and directing customers to the contact us page instead

6.9.43

6.9.42

6.9.41

6.9.39

6.9.38

6.9.37

6.9.36

6.9.35

6.9.34

6.9.33

6.9.32

6.9.31

6.9.30

6.9.29

6.9.28

6.9.27

6.9.26

6.9.25

6.9.24

6.9.23

6.9.22

6.9.21

6.9.20

6.9.19

6.9.18

6.9.17

6.9.16

6.9.14

6.9.13

6.9.12

6.9.11

6.9.10

6.9.9

6.9.8

6.9.7

6.9.6

6.9.5

6.9.4

6.9.3

6.9.2

6.9.1

6.9.0

6.8.5

6.8.4

6.8.3

6.8.2

6.8.1

6.8.0

  • Changed: Enhanced security pasture by escaping potentially harmful output, if information was directly modified in the DB or not escaped during storing AAM settings, reported by WordPress Plugin Review Team
  • Fixed: Cleared potentially corrupted data about status of premium add-ons.

6.7.9

6.7.8

  • Changed: Adjusted suite of automated tests, confirmed that AAM is compatible with the latest WP version

6.7.7

6.7.6

6.7.5

6.7.4

6.7.3

6.7.2

6.7.1

6.7.0

6.6.4

6.6.3

6.6.2

6.6.1

6.6.0

6.5.4

6.5.3

6.5.2

6.5.1

6.5.0

6.4.3

6.4.2

6.4.1

6.4.0

6.3.3

6.3.2

6.3.1

6.3.0

6.2.2

  • Fixed Bug: Backend Dashboard index.php still could be restricted with Backend Menu service
  • Fixed Bug: Policy Generator – Fatal error with PHP lower than 7.0.0
  • Fixed Bug: Policy Validator – Improper dependency validation when if it is not installed
  • Fixed Bug: Default access settings not propagated to user that does not have any roles (multisite setup)
  • Fixed Bug: Reset settings where not synced across all subsites in multisite setup
  • Added New: Ability to define wildcard BackendMenu resource with Access Policy
  • Added New: Ability to define wildcard Metabox resource with Access Policy
  • Added New: Ability to define wildcard Widget resource with Access Policy
  • Added New: Ability to define wildcard Toolbar resource with Access Policy

6.2.1

  • Fixed Bug: Very minor UI issue with Access Policy Delete pop-up
  • Added New: Enhanced Access Policy with new POLICY_META token
  • Change: Access Policy post type supports custom fields now

6.2.0

6.1.1

  • Fixed Bug: Unnecessary backslashes before displaying the access policy https://forum.aamplugin.com/d/432-access-policy-ui-escaping-slashes
  • Fixed Bug: aam_access_dashboard custom capability caused “Access Denied”
  • Change: Enforcing default 307 Temporary Redirect code if none is provided for any AAM redirect functionality
  • Change: Persisting the last managed role, user or visitor on the AAM page
  • Change: Improved safety by using the last role on the list instead of the default Administrator role
  • Change: Optimized access policy service. Changed the way it is applied to any given object
  • Added New: Migration script that clears previously detected migration errors

6.1.0

  • Fixed Bug: Access Policy UI – the “Attach to Default” button was not rendering correctly
  • Fixed Bug: Role Management UI – the PHP notice where Undefined variable: parent
  • Fixed Bug: AAM UI page – improperly compressed HTML response if server config does not match PHP executable INI settings
  • Fixed Bug: Login Redirect Settings – incorrectly merged settings for multi-role support
  • Fixed Bug: Logout Redirect Settings – incorrectly merged settings for multi-role support
  • Fixed Bug: Access Denied Redirect Settings – incorrectly merged settings for multi-role support
  • Fixed Bug: API Route Settings – incorrectly halted inheritance mechanism
  • Fixed Bug: Admin Toolbar Settings – incorrectly halted inheritance mechanism
  • Fixed Bug: URI Access Settings – incorrectly halted inheritance mechanism
  • Fixed Bug: Content Visibility Settings – incorrectly merged settings for multi-role support
  • Fixed Bug: Access Policy Core – incorrectly managed internal cache
  • Fixed Bug: AAM Core – incorrectly managed internal object cache
  • Fixed Bug: Content Service – incorrectly mapped do_not_allow capability if any of the registered post types have it
  • Fixed Bug: Content Service – fatal error Cannot use object of type Closure as array https://forum.aamplugin.com/d/354-php-fatal-error-cannot-use-object-of-type-closure-as-array
  • Fixed Bug: The aam_show_toolbar capability was not taken in consideration
  • Fixed Bug: Logout Redirect Service – White screen occurs if “Default” option is explicitly selected https://wordpress.org/support/topic/blank-log-out-page-on-6-0-5/
  • Change: Refactored internal inheritance mechanism where AAM objects no longer responsible to check for inheritance flag. This eliminates several constrains that we discovered recently.
  • Change: Multiple minor changes to the codebase to consume internal AAM API in more consistent way
  • Change: JWT & Secure Login Services – enriched RESTful API error responses with more details about an error
  • Change: Content Service – optimization improvements
  • Added New: Implemented new filter aam_token_typecast_filter for Access Policy for custom type casting
  • Added New: Implemented support for the => (map to) operator for the Access Policy
  • Added New: Implemented support for the AAM_CONFIG marker for the Access Policy

6.0.5

  • Fixed Bug: Refactored the license managements. Fixed bugs with license registration https://forum.aamplugin.com/d/356-unregistered-version-message
  • Fixed Bug: Some servers do not allow WP core string concatenation. This was causing 403 https://forum.aamplugin.com/d/389-message-loading-aam-ui-please-wait-403-forbidden
  • Fixed Bug: Media list on Posts & Terms tab is not rendered correctly due to improperly managed DB query for post type attachment
  • Fixed Bug: AAM core getOption method did not deserialized settings properly in some cases
  • Fixed Bug: Access Manager metabox was rendered for users that have ability to manage other users https://forum.aamplugin.com/d/371-you-are-not-allowed-to-manage-any-aam-subject
  • Fixed Bug: Logout redirect was no working properly https://forum.aamplugin.com/d/339-problem-with-login-shortcode-and-widget
  • Fixed Bug: The Drill-Down button was not working on Posts & Terms tab
  • Fixed Bug: Access policy Action “Create” was not converted at all for the PostType resource
  • Change: Simplified the first migration script by removing all error emissions. We captured enough migration logs to be confident about proper migration of the most critical settings
  • Change: Changed verbiage for the Enterprise Package on the Add-ons area
  • Change: Added info notification to the Posts & Terms tab for proper Media access controls
  • Change: Merge internal Settings service with Core service
  • Change: Added new migration script that fixed issues with legacy names for premium add-ons
  • Change: Added new internal AddOn manager class
  • Added New: Added the ability to check for new add-on updates from the Add-ons area
  • Added New: Published free AAM add-on AAM Protected Media Files https://wordpress.org/plugins/aam-protected-media-files/

6.0.4

  • Fixed Bug: https://forum.aamplugin.com/d/367-authentication-jwt-expires-fatal-error
  • Fixed Bug: JWT validation endpoint did not check token’s expiration based on UTC timezone
  • Fixed Bug: Removed unnecessary console.log invocations from the aam.js library
  • Fixed Bug: Fixed the potential bug with improperly merged options when access policy Param’s Value is defined as multi-dimensional array
  • Fixed Bug: https://forum.aamplugin.com/d/339-problem-with-login-shortcode-and-widget
  • Fixed Bug: https://forum.aamplugin.com/d/371-you-are-not-allowed-to-manage-any-aam-subject
  • Fixed Bug: Incompatibility with plugins that are extremely aggressive and modify the WP_Query “suppress_filters” flag. Shame on you guys!

6.0.3

  • Fixed Bug: Fatal Error – Class ‘AAM_Core_Server’ not found. https://forum.aamplugin.com/d/358-uncaught-error-class-aam-core-server-not-found
  • Fixed Bug: Fixed the bug where post types that do not have Gutenberg enabled are not shown on the Metaboxes & Widgets tab https://wordpress.org/support/topic/in-metaboxes-widgets-no-pages/
  • Fixed Bug: Not all possible post types are shown on the Posts & Terms tab

6.0.2

  • Fixed Bug: https://forum.aamplugin.com/d/361-uncaught-error-call-to-a-member-function-settimezone-on-boolean
  • Fixed Bug: https://forum.aamplugin.com/d/378-aam-6-0-1-conflict-with-acf-advanced-custom-fields
  • Fixed Bug: Migration script, fixed couple more minor bugs that were causing warnings

6.0.1

  • Fixed Bug: Numerous bugs fixed in the migration script. New script prepared to do additional clean-up and fix corrupted data
  • Fixed Bug: https://forum.aamplugin.com/d/369-notice-undefined-offset-1-service-content-php-on-line-509
  • Fixed Bug: https://wordpress.org/support/topic/6-0-issues/
  • Fixed Bug: https://forum.aamplugin.com/d/353-comment-system-activated
  • Fixed Bug: Migration script was skipping access settings conversion for roles that have white space in slug
  • Added New: Additional migration script for clean-up and fixing corrupted data

6.0.0

  • Complete rewrite of the entire plugin. For more information, check this article

5.0

  • Added ACCESS COUNTER option to Posts & Pages
  • Added premium MONETIZE option to Posts & Pages
  • Added ability to …

Try other plugins

Classic Editor icon

Classic Editor

4.9 · 9M+ installs

Enables the previous "classic" editor and the old-style Edit Post screen with TinyMCE, Meta Boxes, etc. Supports all…